Error con Plex XML

Obsydian, Cool:Plex, Advantage Plex, AllFusion Plex...

Moderadores: Jorge Ubeda, pacopicon

Error con Plex XML

Notapor Gallego » Lun Nov 28, 2011 9:27 am

Hola a todos:

Estamos haciendo pruebas con Plex XML, para comprobar la pontencia que tiene la herramienta en la generación Web, pero estamos teniendo algunos problemas, y era para ver si alguno de vosotros está trabajando con esta herramienta y nos puede ayudar.

Yo me he descargado el tutorial y lo he seguido, pero no nos funciona correctamente, y más concretamente…

La aplicación arranca y puedo hacer login en ella correctamente, incluso puedo crear registros nuevos (Los veo en la BBDD al hacer un select sobre ella), pero los grid no me funcionan ya que no me muestran datos, no me dan error aparentemente, pero no muestran ninguna información.

Creo entender que el grid para recuperar los datos llama a una función llamada FindBrowse, y esta función, llama a otra llamada BlockFetchSQL, que ejecuta un SQL con un parámetro, este parámetro es todo una sentencia SQL que se encarga de recuperar los datos de la BBDD.
Yo miro el Log que genera el tutorial en el Tomcat, y no veo nada raro, me genera miles de filas y entre ellas puedo ver como llama a la función EmployeeFB, pero no veo ningún mensaje de error, (la verdad es que no me entero de casi nada de lo que pone en el log, pero no pone ERROR).

Pero he descubierto otro fichero de “log” dentro del Tomcat, en la ruta /temp/Plex-Beans.log en el que he encontrado el siguiente error:

Fri Nov 25 14:33:26 CET 2011 Type=33You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''select A.ProID ,A.ProDesc,A.ProStartDate,A.ProEndDate from ProjectT A Orde' at line 1 SP=?


Este error me lo da el MySQL, pero no entiendo muy bien porque. Si utilizo SQLserver, me da otro error distinto, pero que viene a decir lo mismo.
El SQL que ejecuta creo que está correctamente, el mismo lo puedo ver en el fichero que se genera en la carpeta temp del Tomcat, más concretamente en el fichero EmployeeFB-doc.xml , y el SQL es:

select A.EmpID ,A.EmpName,A.EmpHireStatus,A.EmpEmail from EmployeeT A Order By A.EmpName ASC limit 400


Hay una nota sobre esto o algo parecido en http://wiki.plex-xml.com/index.php/Plex_6.0 , no sé si estará relacionado pero comenta algo por el estilo, pero yo estoy usando la versión 6.0 build 47.030 de Plex y creo que no me afecta.

A ver si me podeis echar una mano.

Saludos
Última edición por Gallego el Lun Nov 28, 2011 10:32 am, editado 1 vez en total
Gallego
 
Mensajes: 6
Registrado: Lun Oct 03, 2005 12:22 pm

Notapor Gallego » Lun Nov 28, 2011 10:30 am

Ya he solucionado el problema.

Para arreglarlo solo tenía que actualizar mi modelo local del tutorial de Plex, desde el modelo de grupo.

Al actualizarlo y realizar todo el proceso nuevamente, ya funcionó todo correctamente.

Saludos
Gallego
 
Mensajes: 6
Registrado: Lun Oct 03, 2005 12:22 pm


Volver a Plex

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 0 invitados

cron