Problemas en tiempo de ejecución CA Plex 6.1 gen: WinNTC

Obsydian, Cool:Plex, Advantage Plex, AllFusion Plex...

Moderadores: Jorge Ubeda, pacopicon

Problemas en tiempo de ejecución CA Plex 6.1 gen: WinNTC

Notapor Jorge Keil » Mar Nov 01, 2011 2:19 pm

Por favor, si alguien está usando CA Plex r6.1 generador: WinNTC, es decir c++ en cliente y c++ en el servidor. Tenemos problemas en tiempo de ejecución, los clientes no pueden acceder al servidor, hasta ahora hemos utilizamos el mismo generador, con la version 5.5 SP1 de Plex y no tuvimos problemas. En la configuración del archivo .ini solamente indicamos el nombre del servidor.
Jorge Keil
 
Mensajes: 7
Registrado: Jue Oct 27, 2005 2:27 pm
Ubicación: Argentina

Notapor Rolin33 » Mié Nov 02, 2011 9:26 pm

Hola, ademas del servidor en el ini tambien debes poner el Environment (ejm Environment = APPDTA800). Si trabajas con windows XP a mi me dio problemas el SP2 lo solucione instalando el SP3 de windows XP, no olvides de tener el Framework 3.5 y tambien me ha ocurrido que instalando el Client Access 6.1 se me arreglo, debe ser porque instala o arregla algún servicio.
En mi caso sucedio que me dio problemas el tener 2 versiones de c++ en la computadora donde compilo, seria mejor que solo tuvieras el c++ 2005 y prueba compilar desde otra computadora.
Revisa tambien autorización a la Base de Datos.
Rolin33
 
Mensajes: 109
Registrado: Lun Ene 03, 2011 10:14 pm
Ubicación: Peru

Notapor Jorge Keil » Jue Nov 03, 2011 12:33 pm

muchas gracias por responder, quería saber si tenes en funcionamiento aplicativos con Plex 6.1 c/el generador WinNTc, para saber si funcinoa en su version original y si bajaste algun parche para plex r6.1 o para el .net 2005, gracias.
Jorge Keil
 
Mensajes: 7
Registrado: Jue Oct 27, 2005 2:27 pm
Ubicación: Argentina

Notapor Rolin33 » Jue Nov 03, 2011 4:10 pm

Hola, si tengo en funcionamiento aplicativos en Plex 6.1 con el generador WinNtc y me funciona bien en su versión original. Solo tuve que realizar los pasos que te mencione anteriormente. Espero te sirva la información.
Saludos.
Rolin33
 
Mensajes: 109
Registrado: Lun Ene 03, 2011 10:14 pm
Ubicación: Peru

Notapor Manuel » Vie Nov 11, 2011 12:49 pm

Hola Rolin el problema que estamos teniendo es cuando ejecutamos la aplicación con un usuario no administrador, las maquinas estan en dominio y solo funcionan con el administrador del Dominio, Ca tiene un parche para esto, lo aplicamos pero sigue sin funcionar. La duda que tengo es la configuración del INI dado que nosotros dejamos el Environmet por Default y vi que tiene varios parámetros de conexión a la base de datos vos has reformado algo ?? Saludos
Manuel
 
Mensajes: 2
Registrado: Vie Nov 11, 2011 12:40 pm

Notapor Rolin33 » Mar Nov 15, 2011 12:28 am

Hola Manuel, yo tuve un problema parecido y tuve que realizar lo siguiente:
En mi servidor tengo los programas winc, winntc, la base de datos SQL y el dispatch. En este servidor tuve que crear el perfil de todos mis usuarios del dominio, tambien prueba poniendo como administradores a los usuarios, es posible que sea un problema de autorizaciones de los usuarios.
Mi ini yo lo tengo de la siguiente manera:

[RemoteWinNT]
System=APPSERVER1
OpSys=WINNT
Protocol=NTRPC
Program=PLEX_NT_DISPATCHER
Environment=APPDTA700
UseSecurity=False
SecurityLevel=1
Path=
Buffer Size=1
RpcProtocol=ncacn_np
RpcEndPoint=
RpcOptions=
RpcBindDynamic=False

Con poner el servidor y environment correcto debe funcionarte.
Bueno suerte y espero se les resuelva.

Saludos
Rolando Flores.
Rolin33
 
Mensajes: 109
Registrado: Lun Ene 03, 2011 10:14 pm
Ubicación: Peru

Notapor Manuel » Mar Dic 06, 2011 10:43 pm

Rolando tenemos una similar configuración del servidor (Winc, Winntc, Dispatch y BD), cree los Usuarios como administradores, y sigue sin andar. La verdad que no se que puede ser.
Abusando de tu buena voluntad me gustaría pasarte un mail con las pantallas que tenemos de Configuración sobre todo en Environment Manager que es donde tenemos dudas de la configuración.
Saludos y Gracias
Manuel
 
Mensajes: 2
Registrado: Vie Nov 11, 2011 12:40 pm


Volver a Plex

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados