YOBSYTCPDP y YOBSYTCPCT Plex 6.1 AS/400 V5R4

Obsydian, Cool:Plex, Advantage Plex, AllFusion Plex...

Moderadores: Jorge Ubeda, pacopicon

YOBSYTCPDP y YOBSYTCPCT Plex 6.1 AS/400 V5R4

Notapor miguel genoves » Vie Ene 14, 2011 11:26 am

El listener arrancado en mi AS/400 es YOBSYTCPDP.

/Trabajo actual Tipo % CPU Función
PLEX61LSTN QSECOFR BCH 0,0 PGM-YOBSYTCPDP

Los clientes se conectan con YOBSYTCPCT. Haciendo WRKACTJOB veo:

/Trabajo actual Tipo % CPU Función
YOBSYTCPCT USUARIO1 BCI 0,0 PGM-YOBSYTCPCT

Si selecciono el trabajo con 5 para ver el detalle, observo lo siguiente.
Trabajo: YOBSYTCPCT Usuario: QSECOFR Número: 123321

El usuario ya no es USUARIO1, sino QSECOFR que es el que inicia el listener.

¿Es normal? Porque hay programas en ILE-RPG que me funcionan con versiones anteriores y que al llamarlos desde PLEX 6.1 no funcionan.
miguel genoves
 
Mensajes: 11
Registrado: Mié Feb 08, 2006 6:00 pm

correcto

Notapor Jorge Ubeda » Vie Ene 14, 2011 11:56 am

Usuario dueño del trabajo, el que arranca Yobsytcpdp. Usuario actual (current), el que inició una solicitud del despachador. En WRKACTJOB se pueden ver con F11 uno u otro.
Problemas con ILE, habría que verlos caso por caso. Pueden ser incidencias normales.
Jorge Ubeda
Site Admin
 
Mensajes: 229
Registrado: Mié Oct 26, 2005 6:00 pm
Ubicación: Valencia

Notapor miguel genoves » Mié Ene 19, 2011 11:21 am

Solventado el problema. El programa ILE RPG comprobaba que el usuario estuviese dado de alta en una tabla de permisos. Y como para Plex 6.1 USER y CURUSER no son el mismo daba el error. En versiones anteriores, USER y CURUSER son los mismos.

Gracias y saludos.
miguel genoves
 
Mensajes: 11
Registrado: Mié Feb 08, 2006 6:00 pm


Volver a Plex

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 8 invitados

cron